0

I have tried literally everything available on internet for Skyrim infinite load screen (ILS) glitch but it doesn't fix it. It was running perfectly fine the other day and I was on level 15 and half, but today I tried to run it but it just wouldn't run. Also, instead of the ILS my game sometimes crashes too.

Here are my pc specs:

  • Processor: core2quad 3.00ghz
  • Ram: 4gb
  • Graphics card: nvidia geforce 730gt
  • 2
    Sorry to break it to you, but this is not uncommon, and since there are literally thousands of reasons this could happen, it is unlikely we can help. – The Mattbat999 Feb 25 at 16:08
1

Firstly, welcome to the community, thanks for posting.

To get into your question, as the comments have already specified, there are so many things that could cause this and we're not going to be able to pinpoint the exact cause here. The simple fact is the engine behind Skyrim is very old and prone to issues like this. As a developer it's frustrating how poor the engine is. But, as a gamer (whose favourite game happens to be Skyrim) nothing will stop me from enjoying this game.

But, if you've scoured the internet as you suggest there's two key points you have most likely come across:

  1. If you have mods installed, uninstall them one by one starting with the most recently installed one and working backwards. If you installed quite a few at a time (never a good idea) then uninstall in batches of, say 5, and that'll narrow down the culprit to a smaller number of mods. After uninstalling each mod (or batch) start the game and see if it's running. If so, great, you've found the culprit. Go to the mod page and read thoroughly through the installation documentation and requirements to see if you need to do something or have a specific dependency installed.
  2. If you don't have any mods just reinstall the game. Make sure you save your save game files to a backup location (unless you use Steam cloud) and just reinstall it.

You may need to reinstall anyway even if you have mods. Heavily modded games can become very bloated and cause any number of problems. If you're using a mod manager (NMM, Vortex etc.) they can alleviate a lot of the aches of reinstalling all your mods after you've reinstalled the game. An important note; if you do reinstall the game then make sure to delete the entire game folder ("/Program Files (x86)/Steam/steam apps/common/skyrim") as any files added by mods won't be removed upon uninstallation, and there're the most important to remove. Also delete the "[Username]/Documents/My Games/Skyrim" folder (as long as your saves are backed up first).

Personally I find a regular (every 4 - 6 months or so) reinstallation makes for a healthy Skyrim, especially if you frequently install new mods.

Good luck on this quest and I hope you find the solution swiftly.

  • I am sorry,but non of your ideas help me out.I have no mods on this game and I tried to re install this game and saved my save file.still,no luck.i can new game.but I am very far in this game regarding my level and I really don't want to new game.someone on the internet suggested that I should click new game and from there I should use my load.but,when I did that,it showed me that I have no loads.but anyway,thank you for your help. – Asadullah Nizamani Feb 26 at 10:00
  • actually,after deleting the my games skyrim folder,I turned on skyrim and went to continue game.it said "some of the content of the save isn't there.would you like to continue?I clicked yes and my game crashed.but,the second time I loaded the auto save and it worked!I am deeply debted to you as I love skyrim and you solved my problem.a big thank you for helping me out here. – Asadullah Nizamani Feb 26 at 10:07
  • @AsadullahNizamani That message means that one or more of the plugins (the .esm and .esp files in the "skyrim/data" folder) were disabled. When you us plugins in a save (this could be mods, official DLC's or even the "update.esm" file) they are stored in the save. If you then load the game without these files enabled (you can see these in the "Data Files" option is the game launcher) the game will prompt you accordingly. Once you get into the game, save then reload - this will remove the dependency on other plugins. But I would still check which ones you have loaded, you may have disabled DLCs – Kallum Tanton Feb 26 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.