11

I installed Civilization 5 on my laptop recently and there is a problem with the graphics. The game itself looks good, but some resources like sheep are stretched. When I encounter them I see big lines on my screen. It seems as if the textures were stretched.

My laptop specifications:
3 GB RAM; Intel Core i3 CPU; Intel HD Graphics;

I have already installed the latest drivers for my graphic card.

9
  • 1
    Are you running in DX9, or DX10/11? I have a similar issue if I run in DX10/11, but everything works well in DX9.
    – Niro
    Nov 2 '12 at 12:52
  • I tried both DX10/11 and DX9 but I still have the same problem. :/
    – user36401
    Nov 2 '12 at 14:32
  • Does it look a little like this? img12.imageshack.us/img12/594/artifactsi.jpg Nov 2 '12 at 14:42
  • 2
    If it looks like @Ruirize 's artefacts, do the usual graphics card maintenance: reinstall drivers, check overheating, check if it's not loose in its slot (unless it's integrated, of course), reduce overclocking (if you overclock). They tend to appear when something's wrong with the video memory. But since you're not the only one having the issue, it can just as easily be an issue with the game itself. Try fiddling with the graphics settings and contact the developer's support. Dec 7 '12 at 23:59
  • 1
    Correction - These artefacts appear with overheating or faulty hardware caused by overheating. Dec 8 '12 at 0:24
1

Try reinstalling the game. This sometimes happens to people and it happened to me. It worked and I hope it works for you.

1
  • @user36401 if this is the answer your looking for accept it otherwise tell me how I can fix it. Jul 2 '13 at 1:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.