0

I am using Minecraft V 1.2.4 and server v 1.2.4 . I checked on 2 port checkers and got green lights for my external IPv4 connecting to port 25565. I can connect via localhost yet I cannot connect to my external I have tried shutting off my Firewall turning on network sharing. I Was Able to run the server with Hamachi and have other players connect. but I dont like using it and now that I cant figure this out I am Determined to make it work. I run Windows 8.1. Any Suggestions or help is Appreciated

  • want brand/model of router you use to get on internet? probably a port forwarding issue but fetching a guide will require the modem specs. – Lorenzo Boccaccia Jan 23 '14 at 10:27
  • Are you trying to connect to your external address on the same computer running the server? – Slurpee Jan 29 '14 at 19:36
  • Is this for Pocket Edition? Minecraft's current up-to-date version is 1.7.4 – shanodin Feb 21 '14 at 6:39
1

It sounds like you don't have port forwarding set up properly on your router. Merely opening ports through your firewall isn't enough, you're router has to know where to send data coming through a particular port, thus port forwarding. The difference between opening a port in your firewall and port forwarding is this:

Opening port in firewall:

What this does is allow your computer to accept connections through which ever port you open. This would equate to opening a particular door or window to you house so that someone could get in.

Port Forwarding:

Port Forwarding is where you tell your router to route all the data coming in through a certain port to a particular IP on your local network (usually looks something like 192.168.1.xxx) This would equate more to giving someone the instructions to find your house as opposed to opening a door or window for them.

Both are necessary, the data has to know where you computer is on your network and have the door opened so that it can be received by your computer.


A Website you may find helpful is THIS.

That website has instructions on how to port forward for a wide range of diferent router makes and models.


Hope this helps you out!

0

What you're trying to do is called "hairpin NAT". This basically allows you to access your external IP address from inside your network. Most home routers don't support this, causing your problem.

Have a friend on a different network try and connect. If that doesn't work, investigate your port forwarding options.

On another note, why 1.2.4? That's a very old version of Minecraft...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.