5

I upgraded my monitors from 1920x1080 displays to 2560X1440. Now for some reason Steam seems to be low resolution - like it's defaulting to 1920x1080. In every other program, the text is noticeably crisper.

I'm Running Windows 10 Pro. I don't have any issues with any of the games, just Steam itself.

Do I have to uninstall and re-install to fix this?

  • Are you running in Big Picture? – Robotnik Dec 15 '16 at 2:31
  • Nope. Not in big picture mode. I'm just looking at my steam library – KSF Dec 15 '16 at 2:40
7

I believe this might be a Windows 10 display scaling issue. Here's two things to try:

Windows 10 has a display scaling feature. I think for high resolution monitors, it essentially "zooms" in. The display scaling is a setting unique to each monitor. To change it:

  1. Right click on the desktop and select Display Settings
  2. Select the monitor that needs to be adjusted (your new monitor, or if you only have one, the only monitor)
  3. Adjust the slider called Change the size of text, apps, and other items to 100%
  4. Restart your computer. When you load up again, the display scaling should be changed for applications (I believe some things like text will adjust immediately, but some applications such as Steam will need a reboot to adjust the scaling)

(Source)

If this doesn't help, try this solution one user posted on a Steam forum:

To fix it you go to the programs(x86) folder -> Steam -> find the .exe file -> right click and open properties -> compatibility tab -> Check Disable display scaling on high DPI settings -> Apply -> restart your computer and it's fixed. You can do this for any program that has the same issue. Just find the exe file in programs(x86) and do the same thing you did with the Steam.exe.

  • @KSF just note that by adjusting that settings, it affects all apps. I believe if you do the second solution in my answer, it will only affect Steam. – Timmy Jim Dec 15 '16 at 3:19
3

Adding to @Timmy Jim's answer.

This issue affects older Windows operating systems as well, and won't go away until Valve adds HighDPI support to Steam.

Setting Display Scaling to 100% will fix Steam's problem, but in turn will affect every other app on your PC, regardless of whether they support HighDPI or not. Specifically, text and other UI elements will be rendered at an extremely small size, which can adversely affect your productivity.

The better solution is to tell Windows not to scale Steam, and only Steam (and any other app stuck in 2009 that doesn't support HighDPI). @Timmy Jim's alternate solution does just that, so you should try that instead of setting system-wide Display Scaling.

You can also add an exception to the registry. Simply copy the following code...

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files (x86)\\Steam\\steam.exe"="HIGHDPIAWARE"

... into a regular text file and change the text file's extension from .txt to .reg, then double-click the file to execute it. You might need to accept and provide elevated privileges.


You might find that some games won't let you use your screen's native resolution, such as Borderlands 2. The reason for that is the same as with Steam, and the solution is the same.

The beauty about the registry solution, is that you can use it to quickly "fix" multiple apps on multiple PCs. Simply add all the paths you need in the registry file, like this:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files (x86)\\Steam\\steam.exe"="HIGHDPIAWARE"
"C:\\Program Files (x86)\\Steam\\SteamApps\\common\\Borderlands 2\\Binaries\\Win32\\Borderlands2.exe"="HIGHDPIAWARE"
  • Where exactly does that code get copied to? I'm just curious. I can't tell where to place it in the registry editor. – Timmy Jim Dec 15 '16 at 13:46
  • @TimmyJim. Sorry, I forgot to mention that part. I fixed it now. – Nolonar Dec 15 '16 at 14:29
  • Is the Windows Registry Editor Version 5.00 needed also? – Timmy Jim Dec 15 '16 at 14:31
  • @TimmyJim. I never tried it without, but I don't think it's absolutely necessary. – Nolonar Dec 15 '16 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.