0

In dark souls 3 for example, I have this problem:

enter image description here

I have my display set to 1280x1024 on my desktop and I set the graphics xml of dark souls to the same graphics:

enter image description here

And here are my nvidia settings:

enter image description here

I tried ticking the option 'Full-screen' in the scaling mode and nothing happened also.

I also have the same problem with youtube videos with these black borders, I tried switching the resolution to 1024x768 but its extremely bad quality, what can I do, is there a fix other than buying a 1920x1080 screen for now?

2
  • The problem is that 1280x1024 is a 5:4 resolution as opposed to the industry standard 4:3 resolution for non-widescreen displays.1280x960 would be a 4:3 resolution of the same width. That still doesn't explain why the black bars are so tall, though...
    – Powerlord
    May 8, 2020 at 22:23
  • The weird thing is when I switched from windows 7 to windows 10, trying all the nice resolutions possible still gives me black borders in games and youtube videos
    – khaled014z
    May 8, 2020 at 22:42

1 Answer 1

1

The problem is that Dark Souls does not support resolutions other than 1280x720. Even though the game lets you choose another resolution, it will simply scale the image to fit the resolution.

I tried ticking the option 'Full-screen' in the scaling mode and nothing happened also.

There's two (possible) reasons for that:

  1. Since the game is already scaling from 1280x720 to 1280x1024, your GPU no longer has to do any scaling. You should try configuring Dark Souls to run in 1280x720 and setting the scaling behavior of your GPU to "Full-screen" instead of "Aspect ratio".

  2. You left the "Perform scaling on" option to "Display" instead of setting it to "GPU". Your GPU will tell the display to use "Full-screen" scaling, but there's no guarantee your screen will do it. If changing the game's resolution to 1280x720 doesn't work, try to switch to GPU scaling.

As for YouTube, the scaling here is controlled by your browser, which is not configurable (I do not know a single browser that allows configuring scaling behavior).

To fix that, you could try and enable the "Override the scaling mode set by games and programs" option in Nvidia Control Panel (just below the "Perform scaling on" option), although there is no guarantee it will work for all games or programs. For instance, I doubt it will work with Dark Souls, but it might work with your browser. It's worth a try.


If nothing works, buying a 16:9 screen (such as a 1920x1080 screen) will fix this issue for pretty much all games released after 2007. You will still have problems with many movies and some YouTube videos.

A lot of movies (especially those from Hollywood) were made in the 21:9 format and will have black bars even on a 16:9 screen. Also, YouTube videos made by smartphone are often shot in portrait mode, so the aspect ratio will be 9:16 instead of 16:9. This means the black bars will be on the left and right, instead of the top and bottom.

Unfortunately, without full-screen scaling, black bars are inevitable.

1
  • Unfortunately, I don't have the option to choose GPU scaling, and sadly the overriding didn't work for youtube nor dark souls, but thank you for your help, I definitely need to upgrade.
    – khaled014z
    May 9, 2020 at 1:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .