1

I updated my game on steam to the most recent release; 13.0, which came out on the 23rd. Upon starting the game, a new window which I have never seen before showed up:

Image was taken by me, originally uploaded to Reddit, then transferred to here.

The loading bar that can be seen on this window only ever makes it to 50%, which takes less than 2 seconds, and then it crashes. Additionally, attempting to run the application puts two items on my taskbar. One of which has no icon attached to it.

Screenshot of own taskbar. Taken by me.

App B is attached to the window with the loading bar, and App A never appears via a window. When App B crashes, App A lingers for a few seconds before crashing itself.

To fix this, I tried restarting my computer. After that, I received two full lock-ups which required emergency shutdowns, however, this may be unrelated to my problem. This did not fix the problem.

I also tried uninstalling and reinstalling the program, but that did not work either.

I took this problem to Reddit and Steam Discussions and no one has a solution as of now. I don't usually bring technical problems like this to SE, but I really want to get this working again.

If it helps, I am using a 64bit, win10, ASUS Laptop with 7.45 GB RAM. This problem first occurred directly after installing the update. This did not happen before the update because I used this program without issues the day before.


UPDATE

I have decided to see what happens in my Task manager.

A picture of my Task Manager

I noticed that BTD6 starts "suspended" for a while before its status changes to "Not Responding" and then crashing. I also discovered that App B turned out to be a crash handler, which means the app crashes every time without telling me why.


Update 2

I have been emailing Ninja Kiwi directly back and forth for the past week and even they have no solution for this. They suggested I delete everything, as pressing "uninstall" on steam misses a few files. I ended up completely uninstalling the game and deleting these two folders as well:

C:\Users\[my username]\AppData\LocalLow\Ninja Kiwi

C:\Program Files (x86)\Steam\userdata\[my id]\960090

After that, I completely restarted my computer another time. There was absolutely no trace of the game left on my computer.

After reinstalling it and testing it out, it still didn't work. There is clearly something that is not right with my system, but I can't figure out what because I never get an error message when it crashes.

1

Really there is no simple answer. Especially without any error code to go from or anything like that.

A game crash can be anything from a corrupted file, to your system not having the right drivers.

What can you do?

  1. Their support should be the first stop. They made you do what usually is the first step, to start from a fresh install.
  2. Go see if you have any driver updates to do. If you have any to do, do them.
  3. If the game is not online, you might be able to, via steam, download an older version and play on that one. It's somewhere in the options of the game on steam, but can't look it up right now.
  4. Really, as a last hurrah, I would try to see if it's on another store. Maybe their build on steam is bugged, and on another store, it's ok. Check the Windows store and epic games, or even the developper website.
| improve this answer | |
0

I should have answered this myself sooner. It took 2 or 3 weeks of email communication to get a fix, and of all the tests I was sent, there was one test that worked. The game is no longer in version 13.0 and I have not since gotten a crash, but this is what worked back then.

  1. Open this file with a text editor, like notepad:

C:\Program Files (x86)\Steam\steamapps\common\BloonsTD6\BloonsTD6_Data\boot.config

  1. Remove the text nolog=

  2. At the bottom of the file, add the text force-d3d11-bltblt-mode=

  3. Save the file, and launch the game.

After performing this procedure, I haven't had an issue since. Even after updating the game, there is no startup problem. Although, even after the updates, this file remained the same from when I modified it. I am not sure if this edit is continuing to enable me to run the game, but for when the crashes were a problem, this is what worked.

| improve this answer | |
  • modifying the boot.config file didnt work for me, it still crashes with unity crash handler opening up immediately after starting the game :( – bbbbb Apr 10 at 13:38
  • @bbbbb Well, the representative had me take several steps, but this is what fixed it for me. The other steps yielded the exact same results so I concluded that the change to boot.config was the saving grace. She had me delete a few files and she also sent me a .reg file to run. My best advice is to contact NK directly at support.ninjakiwi.com/hc/en-us for anything more complicated. But remember, have patience. I was communicating with them for weeks before my problem was finally fixed. I can't blame them though. I know that they are busy and they did eventually fix this issue for me. – Diriector_Doc Apr 11 at 1:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.